MaDKit forum

Welcome All !
Please, use explicit topic names when creating new threads. Thanks.

You are not logged in.

#1 2012-11-25 01:14:08

Lyes
Member
Registered: 2012-11-25
Posts: 1

Probleme lancement de la platform MadKit 4.2 depuis Eclipse

Bonjour,

J'ai lancer la platforme, j'ai crée un projet sous cette derniere. Mon but est de codé sous eclipse, j'ai crée un projet que j'ai référencer vers le Plugins. La classe crée et tout le reste y est. J'ai ajouté les Librairies qui faut.
Puis, le je vais dans run cinfig, j'ai mis dans Main class : >>>madkit.boot.Madkit<<< et dans argument >>>madkit.kernel.Booter --graphics --config MyProjet.cfg<<<
le fichier cfg c celui qui a été pris depuis le projet.
Quand j'exécute sa me donne :

java.lang.NoClassDefFoundError: madkit/boot/Madkit
Caused by: java.lang.ClassNotFoundException: madkit.boot.Madkit
    at java.net.URLClassLoader$1.run(Unknown Source)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(Unknown Source)

Quand j'execute la platforme solo, ya pas de souci genre variable d'environnement. je comprend pas trop ou est le souci, peut être c argument mais pas sure si quelqu'un peut corrigé ou me proposé une solution.

Merci d'avance
Lyes

Last edited by Lyes (2012-11-25 01:17:09)

Offline

#2 2012-11-25 09:56:16

fmichel
Administrator
From: Montpellier
Registered: 2009-03-24
Posts: 172
Website

Re: Probleme lancement de la platform MadKit 4.2 depuis Eclipse

Bonjour,

Tout d'abord, si vous n'avez pas de raison particulière d'utiliser la version 4, je vous suggère fortement de passer à la version 5 car nous ne faisons plus vraiment de support pour la version 4.
Sinon, a priori, il faut au moins boot.jar dans le classpath du projet pour que cela fonctionne sous la 4 si je me souviens bien.

Bon développement,
Fabien

Offline

Board footer